Incoming call issue from Vodafone to Odisha Location
Resolved
This incident has been resolved.
Posted Apr 11, 2021 - 16:48 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2021 - 14:44 IST
Investigating
We are currently investigating this issue.
Posted Apr 11, 2021 - 13:38 IST
This incident affected: Outgoing Services - Voice (Odisha).