Noticed outgoing call connectivity issue towards JIO Bihar from West Bengal
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 17:19 IST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 09:57 IST
This incident affected: Outgoing Services - Voice (West Bengal).