Call Connectivity issue from Jio Haryana
Incident Report for Kaleyra
Resolved
This incident has been resolved.
Posted 14 days ago. Aug 09, 2019 - 08:57 IST
Identified
Not able to receive incoming calls from Jio Haryana
Posted 14 days ago. Aug 08, 2019 - 13:56 IST
This incident affected: Incoming Services - Voice (Haryana).