IT WB Outgoing Services
Incident Report for Kaleyra
Resolved
This issue resolved from operator end and under observation, For any issues noted please email support@kaleyra.com
Posted 2 months ago. Jan 19, 2019 - 14:56 IST
Investigating
We are investigating the Issue in West Bengal Region and will update once we get further updates
Posted 2 months ago. Jan 19, 2019 - 13:44 IST
This incident affected: Outgoing Services - Voice (West Bengal).