Noted call connectivity issue for all operators in Mumbai
Incident Report for Kaleyra
Resolved
This incident has been resolved.
Posted 29 days ago. Sep 17, 2019 - 20:02 IST
Identified
Noted call connectivity issue for all operators in Mumbai
Posted 30 days ago. Sep 17, 2019 - 16:50 IST
This incident affected: Outgoing Services - Voice (Mumbai).