Noted call connectivity issue for JIO numbers in Odisha
Incident Report for Kaleyra
Resolved
Issue stands resolved and found calls working normal
Posted 9 days ago. Sep 10, 2019 - 19:22 IST
Identified
Noted call connectivity issue for JIO numbers in Odisha
Posted 10 days ago. Sep 10, 2019 - 11:27 IST
This incident affected: Outgoing Services - Voice (Odisha).