Call connectivity issue for local Vodafone numbers in Haryana
Incident Report for Kaleyra
Resolved
This incident has been resolved.
Posted 9 days ago. Sep 11, 2019 - 12:06 IST
Identified
Noted call connectivity issue for local Vodafone numbers in Haryana
Posted 9 days ago. Sep 11, 2019 - 08:48 IST
This incident affected: Outgoing Services - Voice (Haryana).