Noted outgoing call connectivity issue for vodafone numbers in Haryana
Incident Report for Kaleyra
Resolved
This incident has been resolved
Posted 29 days ago. Sep 18, 2019 - 18:07 IST
Identified
Noted outgoing call connectivity issue for vodafone numbers in Haryana
Posted 29 days ago. Sep 18, 2019 - 13:32 IST
This incident affected: Outgoing Services - Voice (Haryana).