Call Connectivity issue with Jio west Bengal
Incident Report for Kaleyra
Resolved
This incident has been resolved
Posted 23 days ago. Aug 28, 2019 - 10:30 IST
Identified
We are observing call connectivity issue with Jio West Bengal
Posted 23 days ago. Aug 27, 2019 - 17:50 IST
This incident affected: Outgoing Services - Voice (West Bengal).