Noted Outbound Call Connectivity issue for Jio Numbers in Jammu Kashmir
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 17:59 IST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2020 - 14:52 IST
This incident affected: Outgoing Services - Voice (New Delhi).