IT TN Outgoing Services
Incident Report for Kaleyra
Resolved
This incident has been resolved.
Posted Sep 06, 2018 - 18:44 IST
Identified
Identified Issue with Outgoing Calls from Tamil Nadu Circle
Posted Sep 06, 2018 - 17:59 IST
This incident affected: Outgoing Services - Voice (Tamil Nadu).