Mumbai Circle - All Operators Incoming Issue
Incident Report for Kaleyra
Resolved
This Issue Stands resolved and functioning normal. Still face an issue in Mumbai Circle, Please email support@kaleyra.com
Posted 13 days ago. Jun 07, 2019 - 18:47 IST
Monitoring
There was no incoming calls from all the operators on incoming to mumbai circle at 2:15 PM IST to 3:15 IST, Currently the services are functioning normal.

This is under Observation
Posted 13 days ago. Jun 07, 2019 - 15:41 IST