Call Connectivity Issue in Ahmadabad location
Incident Report for Kaleyra
Resolved
This incident has been resolved
Posted 22 days ago. Jul 31, 2019 - 10:52 IST
Identified
Call Connectivity Issue in Ahmadabad location
Posted 23 days ago. Jul 31, 2019 - 08:48 IST
This incident affected: Outgoing Services - Voice (Gujarat).